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Introducing ID Flow 
 
ID Flow is premier software for ID card design, production and data management. 
 
This guide provides basic understanding of product components and how to get started. 
This guide is a supplement to the Help Menu provided within the product. The built-in 
Help Menu provides comprehensive configuration details for each dialog.  
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Quick Start Options 

Quick Start Option 1 
ID Flow is preconfigured with several Workstation Profiles. These profiles allow users to 
select an application that resembles their intended use. Profiles are configured with 
sample badge designs, menu options and enrollment processes that are appropriate for 
the application. 
 

 
 
The Basic group has six data fields and a single-layer card design. The Advanced group 
has additional fields, including signature and fingerprint fields, and a multi-layered card 
design. These card designs are linked to a sample database that includes four sample 
records. The card designs, data and data fields may be modified.  
 
To use a pre-configured profile to get started, click on the profile and click Next.  
 
Getting to configuration  
Configuration is done through the Setup button on the Main Menu or through the 
Admin Menu. Only users with Administrative Rights can change settings. After clicking 
Setup you may choose to configure Jolly Server Settings or Workstation Settings. There is 
a shortcut next to the Cardholder Group that will go directly to the Cardholder Group 
Properties dialog. The Record Center button takes you to the database view of all 
records. 
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Click on Record Center to see the fields that are pre-configured in the database.  
 
Editing Card Design  
Each Cardholder Group has an associated ID card design. To edit the card design, open 
the Cardholder Group Properties, select the Card Printing tab and click Edit. 
 

     
 

 
This will launch the card designer.  
 
In the card designer, design objects may be moved and resized with the mouse, deleted 
by selecting delete while the object is highlighted and edited by double-clicking on the 
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object. Design Objects may be added using the design object toolbar on the left of the 
screen and by drawing the approximate object placement on the card with the mouse. 
To change the card size and orientation go to File -> Edit Page Setup. More details about 
ID Flow Designer follow on subsequent pages.  
 
After design modifications are finished click Exit and Save.  
 
For more information, refer to the Card Designer section later in this document. 
 
Other Settings  
Use the Enrollment button on the Main Menu to enroll new cardholders. Modifications 
to the enrollment process, record look up and logs and reports are configured in the 
Cardholder Group Properties.  
 
See records by clicking the Record Center button. Sample records may be deleted, but it 
is suggested a new record be added first so that the data set is not empty.  
 
User Accounts and Locations are configured in Jolly Server Settings and workstation 
tasks are configured in Workstation Settings.  
 

Quick Start Option 2 
Select “Launch Setup Wizard” from the Configure Workstation dialog at start up or run 
from the Setup menu.  
 

    
 

 
Name the cardholder group; then choose the database:  
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Select the card size and then click edit the badge design (see instructions below for ID 
Flow Designer): 
 

    
 
Then configure each tab of the Cardholder Group and Workstation Settings: 
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Using ID Flow 
 
ID Flow has been designed to simplify the day-to-day data entry and production of ID 
cards.  It allows the user to enroll new cardholders, lookup an existing record and view 
reports of all actions that have occurred.  The Record Center shows all database records 
and their ID card design. 
 

          
 
 
Card Issue Center is designed so that multiple locations may be networked through 
sharing a central Jolly Server. For this reason, there are two types of configuration 
settings: Jolly Server Settings and Workstation Options. 
 
To Setup, select the setup button on the Main Menu screen or from the Admin Menu.  
Only Administrators have setup ability. 
 

       
 

Jolly Server Settings and Workstation Options 
 
ID Flow is designed to run across multiple locations in a networked environment.  
Shared settings such as cardholder groups and log data are stored on the Jolly Server 
while workstation specific options are configured in Workstation Options and Devices. 
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If ID Flow will be used in a standalone environment where it does not need to share 
data with other workstations, it can use the Internal Jolly Server, installed as part of ID 
Flow. 

Installing Jolly Server 
 
Jolly Server is installed separately from ID Flow. To install, run the Jolly Server installer 
that was provided to you when you purchased the software on the target server or 
workstation. 

Connecting to a shared Jolly Server – Networking Multiple Copies 
 
When networking multiple copies of ID Flow, install the Jolly Server on a central server 
or shared workstation. All networked copies should point to the same Jolly Server. 
 
To connect to a Jolly Server, select File > Connect to Jolly Server. 

 

   
 

By default, the Internal Jolly Server is selected. When Internal Jolly Server is selected, 
the software will operate in standalone mode. 
 
To connect to a shared Jolly Server, click the Configure button. 
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Enter the name of the server or workstation where Jolly Server was installed. 

Jolly Server Settings 
 
Jolly Server Settings are settings that can be shared between workstations such as 
Cardholder Groups, Locations, Logs and Reports, Security Policy and User Accounts. 
 

 
 
 
Settings for Locations, Logs and Reports Security Policy and User Accounts are obvious 
when the dialog is open. 
 
Cardholder Group settings work in tandem with Workstation settings.  Examples: 1. In 
order to capture a signature in the enrollment process, the signature field must be 
defined in the cardholder group’s Enrollment tab; 2. In order to lookup a record by email 
address, that field needs to be defined in Record Lookup tab; 3. In order to log the name 
and titles of cardholders, those fields must be defined in the Logs and Reports tab. 
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To configure the cardholder group’s settings, highlight the group and select edit. 
 

   
 

Workstation Options and Devices 
 
Workstation Options and Devices apply to only to a specific workstation.  They include 
selecting the location, cardholder groups available at the location, selecting which tasks 
will be available to the user, configuring the tasks and capture devices, and selecting the 
language to be used a this location.  Tasks are configured individually through the task’s 
blue hyperlink or together via the configure button: 
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ID Card Design 
 
Each Cardholder Group has an associated ID card design. To edit the card design, open 
the Cardholder Group Properties, select the Card Printing tab and click Edit. 
 

     

 

Design Screen 
 
The design screen contains four toolbars: general items, alignment tools, design objects 
and object formatting. 
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Cards are designed by selecting the design object on the left-hand toolbar and by 
drawing that object’s area on the card with the mouse.  After the area drawn the 
object’s Properties dialog will appear.  Click through the tabs to format the object. 
 

 
 
Objects may be resized at any time and Properties dialog re-accessed by double-click. 
 

Working with Text 
 
ID Flow contains rich text editing.  Regular text, database text, serial number, date and 
time may be combined within one text box.  Type with a keyboard or use the + Field 
button for text selections. 
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There are three types of text formatting:  Text Box, Flexible Text and Circular Text.  Text 
Box will always place text within the bounds of the box drawn in the design:  If larger, it 
will auto-reduce in font size or word wrap.  Flexible Text will maintain font size 
regardless of the size of the box drawn.  Circular Text formats text in a circle. 
 

 
 

Working with Layers 
 
Like other quality graphical design tools, ID Flow uses a layered design approach.  Layers 
may contain different design objects of varying opacity.  Using layers adds a rich depth 
to design and creates highly secure cards. 
 
To see the layers window click the Show Layers checkbox on the top menu bar.  Layers 
are added using the [+] button at the bottom of the window.  Use the arrow buttons to 
move layers above and below other layers.  Click the Print checkbox on each layer to 
format its print condition.  The active design layer is highlighted blue. 
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Viewing Designs with Live Data 
 
At any time the card design may be viewed with data by checking the Live Data button 
on the top menu bar: 
 

 
 

To view the full record set: go to File -> Database Setup or click the data icon on the top 
menu bar: 

 

Working with Print Conditions 
 
Design objects or design layers may be set to print only if specific database conditions 
are met.  Print conditions are set on the Print Conditions tab of the object’s properties 
dialog.  K Panel (Black Panel) and UV Panel are also set on this tab. 
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Saving a Design 
 
When you are done editing the card design, close the designer to return to the Card 
Issue Center. 
 

Enrollment Configuration 
 
Users define the relevant workflow for enrollment.  Available steps include Data Entry, 
Photo Capture, Signature Capture, Fingerprint Capture and Card Printing: 
 

1.   2.   

 3.  4. 5.  
 
To configure photo capture, driver’s license scan, signature capture and fingerprint scan 
in enrollment, define the processes in the Cardholder Group Properties (Jolly Server 
Settings), and then enable the options and configure the devicese in the workstation 
settings: 
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The capture device specifications are configured by clicking the Options buttons in the 
Workstation Task Settings. 
 
Notes about capture devices:   
 
ID Flow supports TWAIN and WIA compatible cameras.  The ability to capture a photo 
from within ID Flow and trigger the flash will depend upon the camera’s software.  ID 
Flow is commonly used with web cams: When Microsoft WDM is invoked as the capture 
source, four photos are captured and the best may be chosen. 
 

 
 

ID Flow supports Topaz and Interlink USB signature and fingerprint pads. 
 
ID Flow support Card Scanning Solutions ScanShell 800, ScanShell 1000 and SnapShell 
camera for driver’s license and/or passport scanning.  It does NOT support the 800N. 
 
Some device files and drivers may be found under “add-on modules” on the “Download” 
section of the www.jollytech.com website. 
 

http://www.jollytech.com/
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Record Lookup Configuration 
 
Record Lookup allows the user to quickly search for records.  When multiple matches 
occur a selection dialog is shown.  Strict matching may also be used if desired. 
 

 
 

 
 
 
To configure record lookup, first define the lookup fields in the Record Lookup tab of 
Cardholder Group Properties dialog found in Jolly Server Settings. The options can be 
further defined in the Advanced Options dialog. 
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Report Center Configuration 
 
Logs and Reports shows activity on all actions that occur in the product: when a record 
was added, edited or deleted and when card was printed; by whom, at what time and 
location.  Custom logs may be designed.  Reports may be printed, exported and emailed. 
 

 
 
Four fields from a cardholder’s record may be configured in the Logs and Reports tab on 
the Cardholder Group Properties dialog.  The Workstation Setting for Logs and Reports 
makes the item available or not. 
 

Record Center 
 
Record Center is used for the management of records.  Records may be added, edited, 
deleted, printed and duplicated from this screen.  The down-arrow button provides 
additional options. 
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Records may be viewed in single-record or spreadsheet view by selecting the buttons on 
the right of the toolbar. 
 

 
 
Records may be batch printed, deleted and edited by checking the box to the left of the 
record and selecting the appropriate action.  Records may be sorted by clicking on 
column headers. 
 

The toolbar contains filter and sort buttons   .  Filters are used to create data 
subsets.  Sorting allows for multiple field sort criteria. 
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Configuring the Record Screen 
 
ID Flow has drag-and-drop record screen formatting.  Select Edit Record Layout from the 
down-arrow menu on the Record Screen:  Size and move fields with the mouse.   
 

 

Advanced Field Formatting 
 
ID Flow Premier Edition contains advanced field formatting.    Fields may be made 
Visible, Required and Read Only.   They may be given default values.  Drop-down lists 
may be created.  Text can be set to Capitalize, UPPER CASE or lower case.  Image paths 
may be created to store variable images to file.   
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Configuring Language 
 
ID Flow is available in 10+ languages.  Select the language in the Workstation Settings.  A 
translation table allows the user to make changes to the translation or to translate into 
a language not yet provided by Jolly.  After changing languages, restart the program. 
 

     
 
 

 
 
 
The information contained in this document represents the current view of Jolly Technologies on the issues discussed as of the date 
of this publication. This paper is for informational purposes only. Jolly Technologies makes no warranties, express or implied in this 
document. Jolly, Jolly Technologies, ID Flow, Lobby Track, and Command Line Utility are either trademarks or registered trademarks 
of Jolly, Inc. in the United States of America and/or other countries. The names of actual companies and products mentioned herein 
may be the trademarks of their respective owners. 
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